Новости

Обновление исправляет совместимость с Freenode после обновления этой сетью версии IRCd.

Вышел второй релиз-кандидат KVIrc 4.0

Ричард Столлман дал автограф проекту и пожелал успеха в разработке.

Image:Feed.png RSS
Главная страница >

Конфигурирование всплывающих меню

Материал из IRC клиент KVIrc.

Перейти к: навигация, поиск

KVirc позволяет вам изменить практически любое меню программы. Для этого используется Редактор всплывающих меню, который можно открыть с помощью соответствующего пунктна в меню Инструменты программы.

[править] Редактирование меню

Когда вы откроете редактор всплывающих меню, вы увидите в левой его части список установленных всплывающих меню. Там вам нужно будет найти то, которое вы собираетесь отредактировать. Например, меню channel используется, когда вы нажимаете правой кнопкой на нике пользователя в окне канала (или в списке пользователей канала). Выбрав всплывающее меню, в правой части редактора вы увидите сверху предпросмотр этого меню, ниже - редактор кода, и еще ниже - редактор свойств пункта меню.

Для того чтобы удалить какой-либо пункт меню, выделите его и в меню на правой кнопке выберите "Вырезать".

[править] Добавление пункта меню

Допустим, вы хотите добавить в меню, которое появляется при клике на пустом месте в экране канала, пункт меню, при нажатии на который KVIrc будет писать в канал "Здравствуйте, люди!"

  • Для начала нужно открыть редактор всплывающих меню. Как это сделать, оставляю читателю в качестве домашнего задания (ответ: Сценарии>Редактировать всплывающие меню :)).
  • Теперь вам нужно найти меню "channeltextview" и выбрать его.
  • Выберите элемент меню, после которого хотите добавить новый пункт, и нажмите на него правой кнопкой. У вас должна получиться примерно следующая картина:
Создание нового пункта меню
  • Выберите пункт меню "Новый пункт внизу" (он выделен на рисунке сверху)
  • Выделите созданный пункт меню, если он не выделился автоматически, кликнув на нем мышкой
  • Теперь вам нужно заполнить свойства этого пункта.
Редактирование нового пункта меню
    • В поле "Текст" (обозначено на рисунке цифрой 2) нужно вписать видимое имя пункта меню, например, "Поздороваться". Текст может содержать выражение на языке KVS, т.е. быть динамическим.
    • В поле "Условие" (обозначено на рисунке цифрой 3) можно записать условие, при котором пункт меню будет видимым. Для данной задачи его можно оставить пустым, что будет означать, что пункт меню будет видимым всегда.

Условие должно быть написано на языке KVS. Если результат выражения, которое будет написано в данном поле, будет равным 1 или TRUE, то пункт будет видимым, если нет, то не будет. БОлее подробно о том, как писать скрипты на KVS, читайте в [[KVS|соответствующей статье].

    • В поле "Иконка" (цифра 4) нужно записать номер иконки. Номер можно узнать в таблице, которую можно увидеть, если в главном меню выбрать Инструменты->Показать таблицу иконок. Номер иконки складывается из номера ряда+номер столбца. Например, у иконки перезахода на канал номер в таблице - 36.
    • Поле "ID пункта" (цифра 5) - это уникальный идентификатор вашего пункта меню. Он используется скриптерами для своих целей. Оставьте его пустым.
  • Теперь нужно написать код, который будет выполняться, когда вы выберете этот пункт меню в окне канала. Записать его нужно в редактор кода, который на скриншоте отмечен цифрой 1. Например, вы там можете написать
say Здравствуйте, люди!
  • Не забудьте нажать "Применить" или "ОК" перед тестированием своего нового меню:)

[править] Добавление подменю

Теперь, допустим, вы администратор большого канала. И вас не устраивает тот метод бана, которым KVirc банит пользователя. Допустим, вы хотите добавить пункт бана по хостмаске, но не хотите, чтобы он засорял основное меню при клике правой кнопкой на нике пользователя, а хотите добавить вложенное подменю "Продвинутые баны". Опишу вкратце, что для этого нужно сделать.

  • Открыть редактор всплывающих меню. Если вы читаете эту часть статьи, значит, данный пункт уже не должен вызывать вопросов. Если всё же вызывает, то прочтите статью с начала.

Добавление нового подменю

  • Выбираем меню "channel" и выбираем в нем пункт меню, после которого надо добавить новое подменю.
  • Жмем по выбранному пункту правой кнопкой мыши и выбираем "Новое меню внизу"
  • Заполняем свойства созданного меню аналогично заполнению свойств нового пункта меню.
  • Теперь, чтобы создать пункт меню в только что созданном подменю, нужно выбрать его, кликнуть по нему правой кнопкой мыши и в меню выбрать "Новый пункт по середине"
  • Заполните свойства и код созданного таким образом пункта меню. Вы можете добавить и другие пункты в это подменю обычным способом.
Личные инструменты
Инструменты
Наши кнопки
Размести кнопку KVirc у себя на сайте:
www.kvirc.ru - кроссплатформенный IRC клиент с богатым графическим интерфейсом и внутренним языком скриптинга
Друзья и спонсоры
  • Снять Транса в москве цены
  • Fireforge.net
Linux coutner